
Welcome to ArcGIS Data Interoperability

The ArcGIS Data Interoperability extension is an ETL (Extract, Transform, Load) tool for spatial data. The ArcGIS Data Interoperability extension
uses Safe Software's Feature Manipulation Engine (FME) technology. The ArcGIS Data Interoperability extension allows users to integrate spa-
tial data formats into their GIS analysis. Users can directly use, import, and export many vector data formats. In addition, the extension pro-
vides the ability to model new customized spatial data formats based on built-in formats and transformers.

Quick Reference

Add an Interoperability Connection.

Interoperability Connections are useful in the following scenarios:

n maintaining database connections
n viewing formats with non-standard file extensions
n aggregating many tiles of data
n reading data using non-default parameters
n specifying the coordinate system

Import and Export data.

TheQuick Import tool enables you to convert input data formats to a geodatabase. Use this tool in a model to convert your data to a geo-
database for further data processing and editing features. TheQuick Export tool enables you to convert data between formats. You
can use this tool in a model to convert your data to many different formats for delivery to end users.

Create a Spatial ETL Tool.

The Spatial ETL tool is used to manipulate and transform data within the geoprocessing environment. Spatial ETL tools can perform for-
mat translation, and schema and geometric restructuring. For example, you can add, remove or rename attributes, and calculate or
assign values to new or existing attributes.

Create a custom format.

One of the more powerful ways to take advantage of data import capabilities in the ArcGIS Data Interoperability extension is by creating
a Custom Format. A custom format is used if you are often connecting to data in a set schema that requires processing. For example, if
you regularly receive text files in Comma-Separated Value (CSV) format, you might want to develop a custom format to create geometry
from the CSV file, manipulate the attributes, and output linework. Once this custom format has been created, you can simply browse to
any CSV dataset with the same schema, and the processing will happen automatically.

Look up detailed format information.
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Getting Started

Before you begin...

To enable the ArcGIS Data Interoperability extension, you may have to perform one or more of the following steps from within ArcGIS:

Set the Data Interoperability options

1. From the ArcCatalog Tools menu, chooseOptions.

2. Click the General tab.

3. Under Which top level entries do you want the Catalog to contain?

Check the box beside Interoperability Connections.

4. Under Which types of data do you want the Catalog to show?

Check the box beside Interoperability Data.



Enable the ArcGIS Data Interoperability extension

1. From the ArcCatalog Tools menu, choose Extensions.

2. Check the box besideData Interoperability.

Enable the ArcGIS Data Interoperability extension separately in ArcToolbox

1. Open the ArcToolbox window.

2. Click on the ArcToolbox name, right-click and select Add Toolbox.

3. Browse to the Toolboxes folder.

4. Select the System Toolboxes folder and choose Data Interoperability Tools.



Setting Options for the Data Interoperability Extension

Select Options from the ArcCatalog Toolsmenu, and click the Data Interoperability tab.

Cache

Each time data is previewed, the preview is added to the cache. All non-database formats are also indexed and cached to improve performance.

The cache size limit is automatically enforced, according to the size specified in the Cache size field. You can change the default location of the
cache file, or clear the cache.

Catalog

When checked the Data Interoperability extension will examine all .mdb files for Geomedia Warehouses. If not checked, .mdb files will only be
recognized as Personal Geodatabases or Microsoft Access Database files by Data Interoperability tools.

Support

When checked, log files will be generated for Data Interoperability operations. Log files are stored in the folder C:\Documents and Set-
tings\<user>\Application Data\ESRI\Interoperability\logs.

Click here for more information on log files.

File and Directory Locations

Custom Formats

You can delete and modify custom formats from the Reader and Writer Gallery. If, however, you need to e-mail or move a custom format file, by
default they are stored in this directory:

...\My Documents\My FME Datasources

Note: If you are e-mailing a custom format, note that you will also have to include its referenced source data.



.fdl and .fds files

An .fdl file is a small text file that contains settings information for an Interoperability connection. They are used so that the user is not required
to manually enter the connection parameters every time they wish to view a Interoperability connection. Due to the nature of these files, they
can be browsed from the Browse Tree as if they were a data file.

.fds files are text files containing the XML representation of the pipeline of a particular Custom Format. They should never be opened or manip-
ulated outside of Workbench.

Log Files

You can view the log files by clicking the View Logs button under the Tools > Options > Data Interoperability tab.

By default, they are stored under:

C:\Documents and Settings\<user>\Application Data\ESRI\Interoperability\logs

Viewing the Log

The translation log pane displays statistics and processing information that includes the following:

n Data Interoperability version

n reader being used

n writer being used

n logging information

n warning messages

n command line, including published parameters

Information messages are displayed until the translation is complete. When the translation is complete, you can search for text, copy selected
contents of the window directly to another application, or save the contents to a text file.

The log file is an important record of a translation and all the stages and processes within it. At first glance it might appear overly-complex for a
successful translation, but the information in here can be helpful when the output is not what was expected.

ERRORs

An ERROR in the log window signifies a problem that has caused FME to terminate processing. A typical example would be the inability to write
the output dataset. It could just be that the user permissions are not correct, but since FME cannot create an output, there is no need to con-
tinue.

WARNings

A warning in the log window (displayed as WARN) signifies that there is a problem in the processing. The problem was not sufficient to cause
FME to terminate the process, but you’ll want to check that the problem has not adversely affected your output. For example, features with an
incompatible geometry for the destination Feature Type will not cause the process to fail, since FME can filter out these features. However the
output will not be what was expected.

INFORMation

An information message (displayed as INFORM) is a non-error incident which signifies a piece of information that may help you determine
whether your translation has been correctly processed. Typical information would be the number of features processed or confirmation of a par-
ticular setting for that dataset.

STATisticS

Statistics messages (displayed as STATS) provide information on the number of features read from the source and written to the destination
datasets.

Interpreting the Messages

See Interpreting the Log for detailed information on interpreting the contents of the log.
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Note: The text in this area contains important information about the translation. If you ever get results that you did not expect in your out-
put data, check the contents of the log.

Saving Log Files by Default

You can choose to always save your log files:

1. Select Options from the Tools menu and click theData Interoperability tab.

2. Under Log File Defaults, check Save log file. If you want to add information to your log file instead of overwriting it each time you run
the same translation, you can also check Append to log file.

Log files have the extension .log and are saved in the same directory as your workspace file.

Tip: To choose a custom name for the log file, choose Properties from the File menu and edit the Log File field.



Workbench Help

Getting Started with Workbench

About the Workbench Help Files

Please note that there are some user interface differences between the Data Interoperability extension and Workbench. These differences
include the application title bar, as well as command availability in menus, tools, and options.

The top-level topics under Getting Started with Workbench are specific to the Data Interoperability extension.

Some of these topics may differ slightly from similar topics in the Workbench help file, which is also included in its entirety below.

Launching Workbench

You cannot run Workbench independently of ArcGIS. It can only be launched in its capacity as part of the Data Interoperability extension.

Note: You cannot start Workbench by clicking on the workbench.exe file.

To launch Workbench:

n Create a new Spatial ETL tool

n Edit a Spatial ETL tool

n Create a Custom Format

Workbench Interface

In Workbench, you’ll work in workspaces that contain source and destination types (data) and their attributes, as well as transformers that
manipulate the data as it moves from source to destination formats.

Workspace Canvas

The workspace Canvas is where you graphically define your workflow. By default, the workflow reads from left to right; the data source is on
the left, the transformation tools are in the center and the data destination is on the right. Connections between each item represent the flow of
data and may branch in different directions or even lead to a dead-end if required.

Translation Log

The log pane displays a report on translation results. Information includes any warning or error messages, translation status, length of trans-
lation and number of features processed.

Navigator

The navigator is an explorer type tool that displays a text definition of source and destination datasets, plus all the settings that apply to these
datasets.
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Transformer Gallery

The transformer gallery is a tool for the location and selection of FME transformation tools.

Menubar and Toolbar

The menubar and toolbar contain a number of tools: for example tools for navigating around the workspace, controlling administrative tasks
and adding or removing source datasets.

Overview Window

The overview window displays a view of the entire workspace, and highlights the outline of the current canvas window display upon it.

Additional viewing options

Additional panes can display lists of feature and attribute connections.

Show me the canvas.

Show me the Navigator.

Tell me about the translation log.

Tell me how to include transformers in my workspace.

Tell me how tomanage feature type connections.

Tell me how tomanage attribute connections.

Canvas

Themain window (canvas) displays the connections between the source data, transformers, and destination data. Several dockable win-
dows are part of the application. The View > Windowsmenu allows you to specify which information panes are displayed (for example, you
can choose to hide any of the default panes, as well as display additional information about feature and attribute connections).

Example
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You will see a similar view to the example shown above after you create a data transformation tool.

Overview Window

The Overview window displays a mirrored view of the entire workspace.

The outline of the current canvas window is highlighted, so if you have a very large workspace, you can quickly get your bearings in relation to
the rest of the workspace.

If you zoom or pan the canvas window, the overview window also compensates its view; if you move anything on the canvas, it is mirrored in
the Overview window.



Working in the Navigator

The Navigator displays an overview of the source and destination information, bookmarks, workspace parameters and transformers. In general,
it is a hierarchical view of the information in the graphical pane. You can adjust many dataset, feature type and attribute properties from here,
as well as directly in the graphical pane.

One advantage to viewing the information in this pane is that if you have a very large workspace, sometimes it is easier to view all the com-
ponents in list form. You can collapse and expand information much like in a Windows Explorer environment.

You can access functions for all nodes in the Navigator by left clicking on the parameter, and then right-clicking to display a command menu.

Window Management

You can customize the layout of all areas of the Workbench interface. Click View > Windows to see a list of all the panes that you can enable or
disable.

The small arrow (circled below) in the right-hand corner of each pane lets you choose how you want your display (Floating, Stacked or
Tabbed). Click the arrow to display the menu.



By default, the Transformer and Navigator panes are tabbed, meaning that they are displayed on top of each other and you can click their tabs
to toggle between them. If you choose "Float" you can detach a pane from a fixed position and place it where you want by clicking on the frame
of the window and dragging it into a new position. The windows can even float outside of the main Workbench window.

When you have multiple monitors on your system, you can place different panes on a different monitor, leaving the main monitor free to max-
imize the workspace canvas.

You can re-dock panes by dragging them onto the Workbench window frame. Windows can be docked to either the left, right, upper or lower
boundaries of the Workbench frame. When two or more windows are docked in the same location there is the option to arrange them either
stacked or tabbed.

Menus, Tools and Options

Using Workbench Menus and Toolbar Buttons

Menu Bar

The pull-down menus on the top of the Workbench window contain commands that will affect the entire workspace, whereas individual com-
mand menus within the graphical interface (displayed by clicking the right mouse button after making a selection) are applicable to separate
workspace components.

Toolbar

The toolbar gives you quick access to various commands. To see what a toolbar button does without actually selecting it, move your cursor over
the button to view a short description of its function.



Customizing the Toolbar
Right-click on the toolbar and choose Customize Toolbar.

This displays the Edit Toolbar window. From here you can add and remove tools, including transformers.

Including a Transformer in the Toolbar

For one-click access to a transformer (including custom transformers), you can drag it from the Transformer Gallery and place it directly on the
toolbar. Float your cursor over a transformer to see its name.

Status Bar

The area at the bottom left-hand side of the Workbench window displays progress information, as well as short descriptions of selected menu
items or toolbar buttons.

Quick Navigation

To quickly move through a workspace, use keyboard navigation.



n The arrow keys will move you to different parts of a workspace, including links, and the Enter key will open properties for editing.

n Press the Esc key to quickly cancel a pan or zoommode.

n When you are zoomed out in a workspace, you can hover over constants and annotations to display tooltips that show their text.

n Press and drag the middle mouse button (this is the mouse wheel on most mice) to pan around the workspace.

n Hold down the Ctrl key and roll the mouse wheel to zoom in and out.

Choosing from the Formats List

When you choose a reader or writer format from the pull-down menu, the ten most recently used formats
are displayed.

You can also enter a prefix or character string that will display a list of matching selections. For example, if
you type the string "ar" you will see these matches.

To view all formats, click the browse button to display the Reader and Writer Gallery.

About the Reader and Writer Gallery

To display the Reader and Writer Gallery, click the Browse button in any Source or Destination Format field.

The Reader and Writer Gallery displays all formats supported. (Depending on whether you browse from the source or destination format, the
gallery will display formats read or written.) The gallery includes the following information:

n Name: Format name.

n Short Name: This is the common abbreviation for the format name.

n Read/Write: Indicates whether FME reads the format, writes the format, or both.

n Extension: File extension associated with the format.



n Coordinate System: Indicates whether a custom coordinate system is associated with the format.

n Type: Directory-based or file-based format.

n Licensed: Some formats require that you obtain special licensing, or specific versions of FME. This column indicates whether your FME
is licensed to read/write the format.

Note: You can't edit the settings for any of the columns listed above – double clicking on a checkmark will simply select the format and
close the window.

n In List: This column appears only when you are viewing the Formats Gallery from either the Add Source Data or Add Destination Data
dialogs. You can check the boxes in this column to include frequently used format names in the pull-down lists for source and des-
tination data. You can specify a maximum of ten formats.

n Show Formats and Custom Formats

Enabling and Disabling Parts of the Workspace

To quickly enable or disable parts of your workspace, either:

n Use Ctrl+click to select multiple nodes, or press the left mouse button and drag the cursor over a specific area. ChooseDisable or Ena-
ble from the command menu.

n Choose Enable/Disable Nodes from the Tools menu and use the checkboxes.

Note: Especially for larger workspaces, it is sometimes better practice to disable links.

Enabling Single Feature Type Definitions

To output only one feature type, right-click on a feature type definition and, from the command menu, choose Enable This Node Only.

Removing Unattached Nodes

To quickly remove unattached nodes:

n Choose Remove Unattached from the Toolsmenu. A list of unattached nodes appears.

n For large lists, use the search filter to display

n Use the checkboxes to delete the selected nodes, and clickOK.

Edit Parameters

Choose Edit Parameters from the Toolsmenu.



A dialog box will display a complete list of settings from your source and destination datasets. If you have many settings to change at once, this
is the most efficient way to do it.

Edit Header

Note: This is for Advanced FME users.

Choose Tools > Edit Header.

Each format has an associated technical chapter in the FME Readers and Writers manual. This manual lists all the directives available for the for-
mat. However, Workbench does not always contain an associated parameter for these directives.

To include a directive, you can edit the workspace header by finding the relevant header section for the dataset whose directive you need to
add, and inserting it as a macro. For example:

DWG_1_SUPPRESS_FONT_WARNINGS NO

You can also add the directive as a setting in Workbench by using…

DEFAULT_MACRO _SUPP_FONT_DWG_1 NO
      GUI CHOICE _SUPP_FONT_DWG_1 YES%NO Suppress Font Warning:
      DWG_1_SUPPRESS_FONT_WARNINGS $(_SUPP_FONT_DWG_1)

Setting Options

Appearance

Select Tools > Options and click the Appearance icon.

Welcome Dialog
Toggle the checkbox to enable/disable the welcome dialog that appears by default when you start Workbench.

Fonts
Canvas and Log font: Set the default font to be used on the workspace canvas, and in the translation log.

Set Sound Options
You can adjust FME sound events using the Windows Sound and Audio Devices Properties. You can set Workbench to make a distinctive sound
whenever an object is cut, pasted, connected, and deleted. It will also tell you when a translation is successful or has failed. You can also set
two events in the FME Universal Viewer: when a data load is complete, and when a redraw is performed (but only if the redraw is longer than 3
seconds). Note that by default all the sounds are set toOff. Follow these steps to enable them:

1. Click the Configure Sound Events button.

2. Scroll through the Program Events until you find FME Workbench.

3. Select the sound to associate with the applicable event.



4. ClickOK.

Restore Defaults
Click the Restore Defaults button to revert to FME installation defaults.

Runtime

Select Tools > Options and click the Runtime icon.

Set Translation Priority
Sets the CPU priority for running translations. In most cases, the default normal setting will be adequate. If you regularly run large trans-
lations, you can keep the default setting, or change it to low, so the translations won't dominate your CPU (and so you can do other work in the
foreground while the translation is running). If you have other CPU-intensive tasks running concurrently, you may want to set the priority to
high to make sure the translation gets its share of the CPU.

Track Usage Statistics
If you check this box, FME will transmit information about your version of Windows and how you use FME. The information collection process is
completely anonymous, and your results will be automatically combined with other users' results. The resulting statistics will help us identify
trends and usage patterns (for example, which formats and processing facilities are utilized more than others), which in turn will help us focus
our development efforts for future versions of FME. We will not collect your name, address or any other personally identifiable information.

Set Log File Defaults
n Save log file: Save the translation log in the default workspace directory. (When you choose "Save to file" in the log pane, the default
location will be the location you choose under Default Workspace Directory, below. The default filename will be translation_log.txt.)

n Append to log file: Appends log results to the previously generated log, instead of overwriting the file.

Workbench

Select Tools > Options and click the Workbench icon.



Set General Defaults
n Automatically save workspace before running: Automatically saves your .fmw file after a translation, using a default name based
on your source and destination formats.

n Open up attributes when linking transformers: By default, feature types are expanded to display attributes whenever a link is
established.

n Draw bookmarks with a filled background: Bookmarks are shaded instead of transparent.

n Show unexpected input dialog: An important part of FME is being able to choose not to read certain source feature types; this can be
done by removing them from the workspace. For example, if you don't want to read a certain layer in your data, you would delete the
applicable feature type. The Unexpected Input Remover (UIR) is that function that discards such data. It checks the input data against
the structure (or schema) defined in the Workbench or mapping file. If the data doesn't have a matching feature type, it is discarded.
The results of the UIR are noted in the log pane, in two separate places. This checkbox allows you to optionally display the information in
a dialog box. See this fmepedia article for more information on the UIR.

n Allow source feature type editing: This feature, which is unchecked by default, allows you to edit the definition of a source file.

n Enable quick connect: To connect elements of a workspace, you can enable this feature to click an output port, release the mouse but-
ton, and then click an input port. This provides an easy alternative to the "drag and connect" method.

Set Annotation Defaults
n Automatically generate header annotations: New workspaces will appear with the default Source Types, Data Flow, and Des-
tination Types annotations that appear at the top of the workspace.

n Use transparent annotations: Gives annotations a transparent background.

n Automatically create summary annotation: Summary annotations display detailed information on feature types or transformers.

Set Save Options
n Save recovery data: Specify whether (and how often) you want Workbench to write a recovery file for your workspace.

Transformers

Select Tools > Options and click the Transformers icon.

Set Display Options
n Show Transformer Version:With new releases of FME, sometimes we also upgrade transformers to include new functionality. If you
have a large workspace whose history spans multiple FME versions, it may also span multiple transformer versions. Previous versions of
transformers will work the same way they always did, but you might find it useful to also display the transformer versions in your work-
space, especially if you have different versions of the same transformer.

n Truncate names: This option allows you to specify text abbreviations from the left, right or center. For example, if your text consists of
frequently occurring prefixes, you may want to truncate names from either the center or the left so you can see more text at a glance.

Use Drag-and-Insert Transformers
Enables a feature that allows you to drop a transformer onto an existing connection. The defaults you choose here for the input and output ports
will be the default port connections.

http://www.fmepedia.com/index.php/Unexpected_Input_Remover


Workspace

Select Tools > Options and click the Workspace icon.

Stroking
This advanced setting is used by FME whenever arcs need be stroked into lines to make sure the distance between resulting line and the true
mathematical arc is never more than the value specified.

You can set a default tolerance here for all workspaces, or you can set it on individual workspaces through Workspace Settings > Advanced >
Stroking Tolerance.

Geometry Handling

Change the default setting for Geometry Handling.

Note that if you are editing a pre-existing workspace (a workspace that you have saved at least once) and you change the value for this setting
in Workbench Options dialog, the new value will not immediately apply. To affect an existing workspace, you will have to manually change the
value in the Advanced Settings of the Workbench Navigator pane.

If you are working in a new workspace that you have not yet saved, or if you start Workbench and edit this setting, your changes will be applied
immediately.

This behavior prevents overwriting of any values that may have already been saved with a workspace.

Default Paths

Select Tools > Options and click the Default Paths icon.

Default Workspace Folder
Sets the default location to save your workspaces. You can choose to always save to the source data location, a custom location, or aMy FME
Workspaces subfolder in My Documents.

When you create a workspace, FME suggests a default workspace name based on the formats used in the workspace. For example, if your work-
space is set up to read from an ESRI Shapefile and write to both an Access MDB file and AutoCAD drawing, then shape2mdb_dwg.fmwwould
be the suggested default name.

Shared Resource Directories
A shared resource is any FME file that has been made available for other users to use. These files are:

n custom transformers (*.fmx)

n custom formats (*.fds)

n custom coordinate systems (*.fme is best, although most file formats will work)

n transformer categories (*.fmxlist)
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This option is especially useful for workgroups. For instance, if an entire workgroup uses just a few custom coordinate system definitions, keep-
ing these definitions in one place means that everyone doesn't have to have a copy. Then, whenever any of the definitions are updated, the
entire group automatically has access to the new version.

1. Locate the directory that you want to share, and create subdirectories with these names (or, FME will create them automatically for you
during step 5):

n Transformers

n Formats

n Coordinate Systems

Note: Your system administrator may have to set up permissions and subdirectories for this folder.

2. FromWorkbench, select Options from the Toolsmenu and click the Default Paths icon.

3. Click the Add button.

4. Browse to the folder that you want to open for sharing.

5. Click the Open button. If the subdirectories in step 1 do not exist, FME will automatically create them.

The directory name will appear in the list.

Every time you start FME, it will scan the folders for new or updated files.

Note: Any locally stored formats, transformers and coordinate systems take precedence over any shared directories. If there is a naming
conflict, for example, if you have a transformer with the same name as a transformer in a shared directory, FME will always use the trans-
former that is stored locally.

Removing Shared Directories

Select the directory name and click the Delete button.

Coordinate Systems

Select Tools > Options and click the Coordinate Systems icon.

How to maintain and edit grid shift files
This option allows you to maintain and edit grid files. You can manage the grid files by selecting a file and clicking the Edit button (or, simply
double-click the file). The dialog that appears lists one or more grid shift files:

n Move Up and Move Down buttons: Rearrange the precedence of the files.

n Add button: Opens a file browser so you can select a new file and add it to the list.

n Remove button: Delete an entry from the displayed list.

n Fall-back Datum: Select the datum to use if the selected grid file does not cover the area of your input data. Fallback datums are listed
in individual .gdc files, which you can open with any text editor.

Click OK to apply changes, and Cancel to discard changes.



How to add a grid shift file
Follow these steps to install a grid file so that FME will recognize the file:

1. Copy the new file to FME's Reproject\GridData subdirectory.

2. Select Tools > Options and click the Coordinate Systems icon.

3. Select the applicable datum shift and click the Edit button.

4. A dialog displays the files already recognized by FME for the applicable datum shift. To include new files, click the Add button, browse
to the applicable directory and find the file in Reproject\GridData subdirectory.

5. Select the file and click OK.

Printing Workspaces

Default Print Options
Set the following default print options by selecting Page Setup from the Filemenu:

n Page size: Choose from standard page sizes.

n Orientation: Portrait or Landscape

n Page margins: Set margins in millimeters.

n Scale: Choose to always fit the workspace on a page, or always scale to a certain percentage.

n Decorations: Check this box to include file-type information, page number and corner borders on the printout.

Print Preview
Preview a topic before you print by selecting Print Preview from the Filemenu. You can also print from this window.

Print
Bypass preview mode and select Print from the Filemenu.

Setting the Feature Count Display

The feature count display shows how many features passed through each link. This function helps analyze the results of a workspace, and pro-
vides a reference for debugging if the destination results are not what you expected. Feature counts are also written to the Log file but you can
find the references more quickly on the links in a workspace.

To enable feature count display, click the Display Feature Counts tool on the toolbar. Click the tool again to turn off feature counts (although
you will have to run the workspace again to refresh the display).

In this example, you can see that 84 features entered the transformer and that 11 of the features had unique values.

The example below shows the feature counts when spatial and non-spatial data is merged: 10 features from each stream are merged to form
10 output features.





[Link to FME Workbench Help]



Visualizer

Launching the Visualizer

The ArcGIS Interoperablitiy Extension Visualizer is a quick way to view data at any point while it is being manipulated in Workbench.

There are two ways to add a Visualizer:

n adding a Visualizer transformer

n routing output to a Visualizer

Note: You cannot start the Visualizer by clicking on the fmeview.exe file in your installation folder.

Adding a Visualizer Transformer

The Visualizer transformer is located in the Workbench Transformer Gallery, in the Infrastructure category.

1. Double-click the transformer in the Gallery to add it to the graphical display, or click the Visualizer tool on the Workbench toolbar.

2. Connect the Visualizer transformer to any feature type or transformer.

3. There are several options that you can change. Click the Properties button to display the Properties dialog.

Transformer Name: Changes the name that is displayed on the bottom of the transformer, as well as the root name of the data



in the Visualizer.

Note: An easy way to insert a Visualizer is to right-click an output port on a transformer, and choose Connect Visualizer. This will auto-
matically give the Visualizer the same name as the output port.

Attributes to Group By: Groups attributes and treats each group as a separate output in the Visualizer.

Pen Color Override: Forces all attributes to be displayed with the selected color.

Area Fill Color Override: Changes the fill colors of all attributes connected to the transformer.

4. Click the Run button in Workbench to start the Visualizer and display the dataset.

Routing Output to Visualizer

1. Select Route to Visualizer from the Workbench Toolsmenu.

2. Click the Run button in Workbench to start the Visualizer and display the dataset.

This will open a Visualizer with a view of the data at the final stage of processing. Essentially, what you see in the Visualizer should be very
close to the final dataset.

Using the Visualizer

You can further customize the dataset view from within the Visualizer. For example, you might want to:

view specific feature information

set drawing styles

determine distances between two points

mark a location

Visualizer Interface

Visualizer Interface

Every area of the FME Universal Viewer interface has a name and serves a specific purpose. Any of these windows, panes or bars can be dis-
played or hidden by selecting View > Windows in the Menu Bar.





Tip: You can "undock" display panes by clicking on a boundary and dragging it to another location (or by clicking the Max-
imize button ). Holding down the Ctrl key at the same time ensures that the window won't "redock" in another location in
the Viewer.

Display Control Window
The Display Control Window shows a list of open datasets and their various feature types. These components are displayed as a hierarchy of lev-
els that can turned on or off, from entire datasets down to individual geometry types. The Display Control Window also allows you to adjust fea-
ture type symbology and to change the drawing order of data.

Each feature type can be assigned a different color or style that will apply to all geometries beneath it. At the geometry level, each separate type
can also be assigned a unique color or style.

Datasets and feature types are displayed in the same order in the Display Control Window as they appear in the View Window. You can change
this order by dragging any dataset or feature type above another to promote its display order in the View Window. You may only reorder feature
types within their own dataset.

If you want to change the display order of multiple feature types, it is often easier to use the Reorder Feature Types function. Open it by right-
clicking a dataset or feature type in the list and selecting Reorder Feature Types.



The Edit Feature Type Order dialog then allows you to toggle the display of the feature types, re-order them in the list or re-sort them alpha-
betically.

Tip: Hold Ctrl to select successive entries or Shift to select a range of entries.



View Window

The View window is the display area.

You can open multiple datasets at the same time. These are separated by tabs in the View window, and are labelled starting at View 0. You can
also add new datasets to the same viewspace.

Shortcuts

To quickly zoom to a location in the display, hold down the Shift key, press the left mouse button and drag the cursor around the area.

To restore the view, hold down the Ctrl key, press the left mouse button and drag the cursor. Or, hold down the Ctrl key and click the left
mouse button once to zoom out in successive steps.

Log Window

The log window reports information related to the reading and showing of a dataset, which you can use to confirm that data was read correctly.
It shows statistics and processing information whenever you open a dataset using the Visualizer. Certain other functions, such as the Measure
Distances tool also generate messages in the Log Window.

You may find it useful to copy information from the Log File to a text file.



Information Window

When you query a feature in the View window, information about that feature is shown in the Information window.

Feature: The number of features queried. Here it is feature 1 of 1. To the right are buttons to advance or reverse when more than one feature
has been queried. Query multiple features by dragging a box over a region in the View window.

Feature Type: The Feature Type of the feature – LOTS, in this case.

Coord Sys: The coordinate system that the feature belongs to (not filled in when the format does not support coordinate systems).

Attribute Name:

l User Attributes. Some datasets contain attributes that are called, for example, name, parts, acres, points, etc.

l FME Attributes. These start with “fme_” and define the feature within FME. For example, fme_color attributes define a feature’s color
according to FME’s definition method.

l Format Attributes. These define the feature within the source format, using the format’s definition method.

Spatial Summary (beginning with Coord Dimension): includes details on the feature’s dimensionality (2D or 3D), number of coordinates and
bounding box details.

Coordinate Listing: an (optional) full listing of all the coordinates of the feature.

Tip: Double-clicking a coordinate in the Information window coordinate listing highlights that position with a crosshair in the
View window.



Menu Bar
The Menu Bar includes the File, View, Window and Help Menus. The File Menu allows you to perform administrative tasks, such as the opening,
adding and saving of files. The View and Window Menus let you navigate around the View Window and set Viewer options, while the Help Menu
contains links to help files and other FME documentation.

Status Bar
The Status Bar is a general report on the status of the Viewer. It shows which feature is being read when a dataset is opened, indicates when
the Viewer is drawing a dataset on screen and prompts you when the Viewer is waiting for user input.

Options Menu

Selections in the View > Options menu allow you to customize what you see in the Visualizer output.



Mark Vertices
These options, when activated, visibly mark all vertices of Area, Line and/or Text Feature Types.

Unmarked area vertices:

Marked area vertices:



Allow Area Filling

This option fills in all polygons with their associated color (fme_fill_color).

When this option is turned off, polygons will be transparent, allowing you to see through to data below.

Area Filling might be appropriate, for example, in a viewspace depicting bodies of water.

Example with Allow Area Filling turned off.



Example with Allow Area Filling turned on.

Redraw on Theme Change

When you check this option, the dataset(s) in the View Window will be redrawn whenever a theme change occurs (for example, when you
select layers in the Display Control tree). This option is helpful if you have to turn on or off numerous layers and would prefer not to redraw
(repaint) the view each time.

Display Full Decimal Precision

The Visualizer displays coordinates either in a truncated format or in their full decimal precision. The default option is to display truncated coor-
dinates, but full precision is vital for checking geometric processes (such as examining a polygon to ensure that it closes correctly).

Display All Coordinates

When a feature is processed in the Visualizer, its coordinates are listed in the Information window.

Features can have thousands of coordinates. Therefore, in order to preserve Visualizer performance, FME restricts coordinate display to a max-
imum of 50. However, you can choose to enable full coordinate display by selecting this option from the menu.

Adjust Sound Events

You can adjust Visualizer sound events using the Windows Sound Control Panel. To make it easier to find, the Visualizer provides direct links
through the Menu Bar.

You can set two events in the Visualizer: when a data load is complete and when a redraw is performed (but only if the redraw is longer than 3
seconds).

Note that by default all sounds are set to Off. Follow these steps to enable them:

1. Select View > Options > Adjust Sound Events.

2. Scroll through the Program Events list until you find "FME Viewer."

3. Select the sound to associate with the appropriate event.

4. Click OK.

Use Persistent Cache

This function allows the Visualizer to save data in the local file system for subsequent use, such as in situations in which access to the data is
over a low-bandwidth link, access is not available at all, or the dataset is very large.

This is helpful when you need to view a particular viewspace frequently.

Geometry Handling

This option allows you to switch between Classic and Enhanced Geometry handling modes.

Each supported format reacts slightly differently to this setting. For example, if an arc in AutoCAD DWF format is read while in Enhanced Geome-
try handling mode, it is represented as a continuous curve. In Classic geometry handling mode, however, it appears as a series of connected



points that form a curve. In both cases, the actual storage of the feature's geometry is unaffected. The reading of the geometry, however,
varies according to the Geometry Handling setting.

For detailed information on how a particular format responds to Classic or Enhanced Geometry handling, refer to the FME Readers and Writers
manual or to FME Fundamentals (available on our website) . Note that if a reader only supports enhanced geometry (for example, EDIGéO) or
only supports classic geometry (for example, ESRI ArcInfo Generate), it is not affected by the parameter.

Note: Changing this parameter introduces certain limitations. For example, if you open a dataset while in Enhanced Geometry handling
mode, then change the setting to Classic and add another dataset to the same viewspace, both modes are at work simultaneously. If you

refresh the view, however, the reading of both datasets reverts to Classic Geometry handling mode.

Querying Features

Viewing Feature Information

The Information window is on the right-hand side of the Visualizer. By default, this area will be blank.

You can query both classic and enhanced geometry features.

To display feature information:

1. Zoom in to accurately pinpoint a feature.

2. Click the Select Features tool .

3. When the cursor changes to click on the feature. Information will appear in the Information pane.

Tip: To query multiple features, click the Select Features tool and drag a box over a region by holding down the left mouse
button.

Querying Classic Geometry

Below: Information Window with queried feature information
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1) The number of features queried. Here, it is feature 1 of 1. To the right
are buttons to advance or reverse when more than one feature has been que-
ried. Query multiple features by dragging a box over a region in the view
window.

2) The Feature Type of the feature - a city park, in this case.

3) The coordinate system that the feature belongs to. This field will be
blank if the format does not support coordinate systems.

4) User Attributes. This dataset contains attributes called name, parts,
acres, points, etc.

5) FME Attributes. These start with "fme_" and define the feature within
FME. For example, fme_color attributes define a feature's color according to
FME's definition method.

6) Format Attributes. In this case, the format is MapInfo. These define the
feature within the source format. Here, format attributes define a feature's
color using the format's definition method.

7) Spatial Summary: includes details on the feature's dimensionality (2D or
3D), number of coordinates and bounding box details.

8) Coordinate Listing: an (optionally) full listing of all the coordinates of the
feature.

Querying Enhanced Geometry

When you query a feature that has enhanced geometry, the upper part of
the Information window remains the same, but the lower half is different.

This is an Information Window with queried feature information:

1. The feature geometry type. Here, it is a polygon feature (or IFMEPolygon).

2. The boundary of the polygon is defined by a “path” (IFMEPath) made up of
three segments.

3. The first path segment is a line feature (IFMELine). It is a 2D line with three
coordinates.

4. Segment 2 is an arc (IFMEArc). A feature of the geometry model is the abil-
ity to string together arcs and lines within the same path. Notice the start,
end and centre points of the arc are defined as IFMEPoint.

5. The final segment is another line.





Miscellaneous Visualizer Functionality

Marking a Location on a Dataset

The Mark Location feature allows you to pinpoint a location on a dataset. Right-click on any part of the dataset and select Mark Location.

The location will be marked with a red crosshair.

Select the pushpin button in the toolbar to open the Mark Location dialog. From here, you can view and edit the X and Y coordinates of the
marked location. This is useful if you know the coordinates of your intended mark, but do not necessarily know where to find it in the Visualizer,
or if you wish to mark a precise location.

The Mark Location dialog also allows you to specify the radius. If the specified radius is particularly large, a crosshair may no longer be an
appropriate marker. In these cases, the location will be marked by a circle:

Select to zoom immediately to any marked location.

Using the Measuring Tool

The Visualizer supports a “measuring” mode to make it easy to determine distances between two points in a view. One of the advantages to this
tool is that it allows you to determine how close things are so that you can set and adjust tolerances during format transformations.

Click the measuring tool . You will see a crosshair in the viewspace.

Left-click and keep pressing the left mouse button while you drag the crosshair from point A to point B.



Release the mouse button. The log view will show the distance measured, as well as start and end coordinates. For example:

Measured Distance: 0.0237; From (-97.8046,26.3223) To (-97.8088,26.2990)

If you don't have your log view open, this information is displayed in the status bar on the lower left.

Displaying Features

The easiest way to toggle feature displays in the viewspace is by clicking the box next to a feature name. An X means that the feature is cur-
rently displayed. Click to deselect the box and turn off the feature display.

You can also select a feature name and click the right mouse button to display a command menu.

Select Toggle Feature to quickly turn on/off the display.

Select Reorder Feature Types to display the Edit Feature Type Order dialog. From here, you can

l Show/Hide All: Turn on/off the display for all feature types.

l Move Up/Move Down: Change the order of feature types. Press Ctrl + left-click to select multiple feature types.

l Sort: Sorts the list alphabetically.



Note: If you have more than one dataset open, clearing a dataset checkbox turns off data in the view for that particular dataset only.

Setting Drawing Styles

You can adjust how the features are displayed.

1. In the Display Control Window, either right-click on a feature name and choose a feature type from the command menu, or double click
on a feature type. .

2. In either case, the Drawing Styles dialog appears, showing the feature types separated by tabs.



From here you can change color, line style, symbol and text characteristics.

Filtering Features

For advanced users, or users who are familiar with the underlying FME functionality:

Locating a particular feature in a large dataset can be difficult. This Visualizer tool helps by filtering features and retaining only those with attrib-
utes that match a certain criteria.

Example

This data has an attribute called Length.

The Filter Features tool opens a dialog box that contains a Test Expression field. The Left Side is usually a function and the Right Side is
usually a constant.

In this case, the dialog is set up to test for lines with a length of less than 600.



Note: The value in the Left Side text box contains an ampersand (&). This is the filter’s way of specifying the value of the length attribute
rather than the text string “length”.

To display all the features whose width attribute has a value less than 100, you would enter:

Left Side: &width
Operator: <
Right Side: 100

Non-system Encoding

The Visualizer can display attributes held in a non-system encoding, so you won't have to change your computer to a different locale.

Above: Japanese attribute as shown in the Visualizer. Note that the line shown is for display purposes only.



Importing Data

Using Quick Import

Converts data in any supported format into feature classes.

The geodatabase can then be used, or further post-processing can be performed. Individual feature classes from the staging geodatabase can
be operated on using the Select Data tool.

1. Under Data Interoperability Tools in ArcToolbox, choose Quick Import.

The Quick Import dialog appears.

If you created a custom toolbox, you can add the Quick Import selection:

n Right click on the new tool, and choose Tool... from the Add menu:

n Then click the Data Interoperability Tools checkbox:

2. Click the Browse button in the Input Dataset field.

The Specify Input Data Source dialog appears:

3. Select the Source Format

Select the format of your source data. You can also click the Browse button to choose from the Formats Gallery.

4. Locate Source Data

Type the location of your input data. You can also use the buttons to browse for files or addmultiple datasets. If the source format has
specific default settings that you want to change, you can edit them here.

For Settings Box Help: Press the Help button, the F1 button on your keyboard, or click the question mark in the upper-right portion of
the Settings Box.
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5. Coordinate System

By default, the Data Interoperability extension either uses a default value or uses the coordinate system referenced in the input dataset.
For systems that know their coordinate system, this field will display "Read from Source” and the coordinate system will be read from
the source dataset. For most other input sources, the field will display “Unknown” (which simply means that the default values will be
used). In most cases, the default value is all you’ll need.

To specify a different coordinate system for the data, click the Browse button in the Coordinate Systems field to display the Spa-
tial Reference Properties dialog. Refer to the ArcGIS Help files for more information on coordinate systems.

6. Specify a filename (or use the default) for the output staging geodatabase, and click OK.

A status window appears, which displays information and statistics about the Import function. When the import is complete, you can
close the window.

More Information: usage tips, command-line syntax, and scripting syntax.

Quick Import

Converts data in any format supported by the ArcGIS Data Interoperability extension into feature classes.

The output is stored in an interim staging geodatabase. The geodatabase can then be used or further post-processing can be performed.

Usage Tips

n This tool is used to either bring data into the ArcGIS environment, or as the beginning point in a model or script where data from outside
ArcGIS will be processed.

n The feature classes generated depend on the input data. For instance, if you import two MapInfo MIF/MID files, two features classes will
be created.

n This tool creates a new personal geodatabase, and will not append to an existing one.

n The feature classes generated from the imported data can be accessed using the Select Data tool on the output staging personal geo-
database.

n As data is imported, no changes to the data model are made. To transform the data model during import, a Custom Data Import Tool
should be created and used.

n The following environments affect this tool: extent, workspace, scratchWorkspace, MDomain, outputMFlag, outputZFlag, outputZFlag,
spatialGrid1, workspace, XYDomain, ZDomain.



Command-line syntax

QuickImport <Input> <Output>

Parameters

Expression Explanation
<Input> The data to be imported. The command syntax can take multiple

forms:

n If the source data is a file with a well-known file extension,
it can be given as-is. For instance: "c:\data\roads.mif"

n If the source data is not a file, or the file has an unknown
extension, the format can be given as part of the argument,
seperated by a comma. For instance:
"MIF,c:\data\roads.mif". The names for supported formats
can be found in the Reader and Writer Gallery, by opening
this tool in dialog mode and clicking the browse button.

n Wildcards can be used to read in large datasets. For
instance: "MIF,c:\data\roads*.*"

n The * character matches any series of characters
for all files in the current directory. For instance,
c:\data\roads*.mif will match c:\data\roads.mif,
c:\data\roads5.mif, and c:\data\roads-updat-
ed.mif.

n The ** characters match any subdirectories, recur-
sively. For instance, c:\data\**\*.mif will match
c:\data\roads.mif, c:\data\canada\rivers.mif, and
c:\data\canada\alberta\edmonton.mif.

n Additional format-specific parameters can be added after
the dataset, separated by a comma. However, the syntax
can be complex, so if this is required it is easiest to run the
tool in its dialog box in ArcToolbox and copy the command
syntax from the results window.

<Output> The output staging personal geodatabase.

Command-Line Example

QuickImport c:\Data\roads.tab c:\out\roads.mdb
QuickImport MIF,c:\Data\*.* c:\out\alldata.mdb



Scripting syntax

QuickImport (Input, Output)

Parameters

Expression Explanation
Input Dataset (Required) The data to be imported. The command syntax can take multiple

forms:

n If the source data is a file with a well-known file extension,
it can be given as-is. For instance: "c:\data\roads.mif"

n If the source data is not a file, or the file has an unknown
extension, the format can be given as part of the argument,
seperated by a comma. For instance:
"MIF,c:\data\roads.mif". The names for supported formats
can be found in the formats gallery, by opening up this tool
in dialog mode and clicking the browse button.

n Wildcards can be used to read in large datasets. For
instance: "MIF,c:\data\roads*.*"

n The * character matches any series of characters
for all files in the current directory. For instance,
c:\data\roads*.mif will match c:\data\roads.mif,
c:\data\roads5.mif, and c:\data\roads-updat-
ed.mif.

n The ** characters match any subdirectories, recur-
sively. For instance, c:\data\**\*.mif will match
c:\data\roads.mif, c:\data\canada\rivers.mif, and
c:\data\canada\alberta\edmonton.mif.

n Additional format-specific parameters can be added after
the dataset, separated by a comma. However, the syntax
can be complex, so if this is required it is easiest to run the
tool in its dialog box in ArcToolbox and copy the command
syntax from the results window.

Output Staging Geodatabase (Required) The output staging personal geodatabase.

Script Example

# Purpose: Import a Mapinfo TAB file, and select a specific layer from it
# Import systemmodules
import sys, string, os, win32com.client
# Create the Geoprocessor object
gp = Dispatch("esriGeoprocessing.GpDispatch.1")
# Local variables...
tab_to_import = "MAPINFO,C:/Data/exercise1/ROADS/roads.tab"
null_mdb = "C:/DOCUME~1/madam/LOCALS~1/Temp/null.mdb"
ROADS_LINE = "C:/DOCUME~1/madam/LOCALS~1/Temp/null.mdb/ROADS_LINE"
# Process: Quick Import...
gp.QuickImport(tab_to_import, null_mdb)
# Process: Select Data...
gp.SelectData_management(null_mdb, "ROADS_LINE", ROADS_LINE)



Exporting Data

Using Quick Export

Converts one or more feature classes into any supported output format.

1. Under Data Interoperability Tools in ArcToolbox, choose Quick Export.

The Quick Export dialog appears.

If you created a custom toolbox, you can add the Quick Export selection:

n Right click on the new tool, and choose Tool... from the Addmenu

n Then click the Data Interoperability Tools checkbox:

2. Click the folder icon to locate a dataset and choose the input layer(s).

Tip: Select more than one layer by pressing the Ctrl key and left-clicking the mouse.

The layers will appear in the list. You can change the order in which they appear, or remove them.

3. Specify the Output Dataset.

Select the format of the output data and choose a dataset name. You can also click the Browse button to choose from the Reader and
Writer Gallery.

For Format Settings Box Help: Press the Help button, the F1 button on your keyboard, or click the question mark in the upper-right por-
tion of the Settings Box.

Note: The output dataset defaults to NULL, which is useful only for testing purposes. Any feature written to it is deleted, and it produces no
output.

4. Click OK.

The output file will be produced. A log window displays the processing information, including the number and type of the features being
written.

More Information: usage tips, command-line syntax, and scripting syntax.

Quick Export

Converts one or more input Feature classes or Feature layers into any format supported by the ArcGIS Data Interoperability extension.



Usage Tips

n This tool is used to either export data from ArcGIS, or as the final step in a model or script where the destination data is external to Arc-
GIS.

n During the export, no change to the data model is made, if this is desired, a custom data export tool should be created and used.

Command-line syntax

QuickExport <Input;Input...> <Output>

Parameters

Expression Explanation
<Input;Input...> The layers that will be exported from ArcGIS.
<Output> The format and dataset that the data will be exported to.

n If the destination is a file with a well-known file extension, it
can be given as-is. For instance: "c:\data\roads.gml"

n If the destination is not a file, or the file has an unknown
extension, the format can be given as part of the argument,
seperated by a comma. For instance: "MIF,c:\data\". The
names for supported formats can be found in the formats
gallery, by opening up this tool in dialog mode and clicking
the browse button

n Additional format-specific parameters can be added after
the dataset, separated by a comma. However, the syntax
can be complex, so if this is required it is easiest to run the
tool in its dialog box in ArcToolbox and copy the command
syntax from the results window.

Command-Line Example

QuickExport c:\Data\roads.shp c:\out\roads.gml
QuickExport c:\Data\roads.shp;c:\Data\rivers.shp MIF,c:\mif-files

Scripting syntax

QuickExport (Input, Output)

Parameters

Expression Explanation
Input Layer (Required) The layers that will be exported from ArcGIS.
Output Dataset (Required) The format and dataset that the data will be exported to.

n If the destination is a file with a well-known file extension, it
can be given as-is. For instance: "c:\data\roads.gml"

n If the destination is not a file, or the file has an unknown
extension, the format can be given as part of the argument,
seperated by a comma. For instance: "MIF,c:\data\". The
names for supported formats can be found in the formats
gallery, by opening up this tool in dialog mode and clicking
the browse button

n Additional format-specific parameters can be added after
the dataset, separated by a comma. However, the syntax
can be complex, so if this is required it is easiest to run the
tool in its dialog box in ArcToolbox and copy the command
syntax from the results window.



Script Example

# Purpose: Buffer any layer and export it to GML
# Import systemmodules
import sys, string, os, win32com.client
# Create the Geoprocessor object
gp = Dispatch("esriGeoprocessing.GpDispatch.1")
# Local variables...
tmp_buffered = "c:/Project/tmp_buffered.shp"
tmp_dissolved = "c:/Project/tmp_dissolbed.shp"
Output_Dataset = "GML2,c:/data/buffered.gml"
Input_Features = ""
# Process: Buffer...
gp.Buffer_analysis(Input_Features, tmp_buffered, "10.000000 Meters", "FULL", "ROUND", "NONE", "")
# Process: Dissolve...
gp.Dissolve_management(tmp_buffered, tmp_dissolved, "", "")
# Process: Quick Export...
gp.QuickExport(tmp_dissolved, Output_Dataset)



Transforming Data

Creating a New Spatial ETL Tool

The Spatial ETL tool is used to manipulate and transform data within the geoprocessing environment. Spatial ETL tools can perform format
translation, and schema and geometric restructuring. For example, you can add, remove or rename attributes, and calculate or assign values to
new or existing attributes.

n Follow the instructions in ArcGIS Desktop Help for creating new toolboxes.

n Right click on the new toolbox and chooseNew > Spatial ETL Tool from the command menu.

n The Create Translation Workspace Wizard appears.

From the wizard:

1. Select the Source Format

Select the format of your source data. You can also click the Browse button to choose from the Reader and Writer Gallery.

Tip: If you have data in multiple formats that you want to merge during import, choose one format here and you
can add others from within Workbench. Search Adding Source Datasets in Workbench Help.

n Click Next.

2. Locate Sample Source Data

The source datasets specified will be used to supply the source schema for the resulting tool. The resulting tool can be run on any input
source datasets of the correct format.

Type the location of your input data. You can also use the buttons to browse for files or add multiple datasets. If the source format has
specific default settings that you want to change, you can edit them here by clicking the Settings button. In most cases, however, the
default settings will be all you need.

n Click Next.

3. Specify Destination Format

Choose a destination format.

Tip: If you would like to export to multiple formats, choose one format here, and then you can add other export
formats from within Workbench.

4. Specify Destination Settings

This destination format has specific settings that you can adjust. In most cases, the default settings are all you will need to create the
custom data export tool. However, if you want to change them, click the Settings button.

5. Click Finish to create a workspace and launch Workbench.

Use Workbench to specify the transformation of the input feature classes into output feature classes.

Using Workbench: More detailed help is available under theWorkbench Help topic. For example, you might want to:

n Add source formats.

n Merge datasets.



n Add transformers.

n Work with feature types and attributes.

n Use the Visualizer to view data.

6. When you have finished in Workbench, choose File > Exit.

What can you do with a Spatial ETL Tool?

Open the Spatial ETL Tool andwrite the feature classes to an output staging geodatabase.

Edit the Spatial ETL Tool.

Opening an Existing Spatial ETL Tool

You can use an existing Spatial ETL Tool to write the feature classes to an output staging geodatabase for further translation into geodatabase
feature classes and tables.

1. Follow the instructions for creating a new spatial ETL tool.

2. From ArcToolbox, double click the Spatial ETL Tool that you want to use, or right-click and choose Open.

The Spatial ETL tool dialog appears.

The input layers and output staging geodatabase fields contain the information that was specified when the transformation tool was
created.

1. Browse to the dataset.

2. Select the dataset (or layer, as shown below).

3. The path will appear in the list.



3. Repeat for each input layer.

4. Click OK.

A status window displays information and transformation statistics while the layers are being written to the output staging geodatabase.

Editing a Spatial ETL Tool

1. Follow the instructions for creating a new Spatial ETL tool.

2. From ArcToolbox, select the Spatial ETL Tool and press the right mouse button.

3. Select Edit from the menu.

4. Workbench starts up, and displays the Spatial ETL tool.



For detailed help with Workbench functions, open theWorkbench Help topic.

5. Save your changes.

Choose Save from the Filemenu, and then exit Workbench.



Custom Formats

Creating a Custom Format

There are several ways to take advantage of the data import capabilities available in the ArcGIS Data Interoperability extension. One of the more
powerful methods involves creating a Custom Format. A custom format is used when users are often connecting to data in a set schema that
requires processing. For example, if users regularly receive text files in Comma-Separated Value (CSV) format, a custom format could be devel-
oped to create geometry from the CSV file, manipulate the attributes, and output linework. Once this custom format has been created, the user
can simply browse to any CSV dataset with the same schema, and the processing will happen automatically. 

You can use a custom format like a standard Source Format. After you create and save the format, it will be selectable from the Reader and
Writer Gallery.

n Display the Reader and Writer Gallery:

Click the browse button from any field that allows you to choose either an input or an output format.

For example, chooseQuick Import and click the Browse button beside the Input Dataset field. Then click the Browse button in the
Specify Input Data Source dialog.

n Click the Custom Formats New button at the bottom of the Gallery window.

The Custom Format wizard will guide you through the following steps:

1. Select the Source Format

Select the format of your source data. You can also click the Browse button to choose from the Reader and Writer Gallery.

2. Locate Source Data

Type the location of your input data. You can also use the buttons to browse for files or addmultiple datasets. If the source format has
specific default settings that you want to change, you can edit them here.

For Parameters Box Help: Press the F1 button on your keyboard, or click the question mark in the upper-right portion of the Parameters
Box, and drop the question mark into the dialog.

3. Select Exposed Parameters

The parameters listed here will depend on your source data, and the ones you select will determine which parameters will be shown
when you use the format in a translation.

4. Name the Custom Format

Enter a short name and description for the custom format. After completing step 6 below, these names will appear in the Reader and
Writer Gallery, in the Description and Short Name columns, as shown in this example:

Workbench will automatically assign a default file extension; however, you can assign any file extension.

../../../../../Content/Merging_Similar_Datasets.htm
../../../../../Content/Merging_Similar_Datasets.htm
../../../../../Content/Merging_Similar_Datasets.htm


WARNING: It is recommended that you do not associate a file extension that is already recognized by ArcGIS or the Data Interoperability
extension, since this will affect standard ArcGIS behavior.

5. Create the Custom Format

After you click Finish, Workbench will open and the custom format's feature types will appear.
Using Workbench: For detailed help, see theWorkbench Help topic.

6. Close the Workbench window

When you are finished, choose either Close or Exit from the Filemenu. The Custom Format will be included in the Reader and Writer
Gallery. To see the custom format, restart Workbench and choose Tools > Browse Formats.

Editing a Custom Format

From the Reader and Writer Gallery, choose the format, then click the Custom Formats Edit button.

Deleting a Custom Format

From the Reader and Writer Gallery, choose the format, then click the Custom Formats Delete button.

Using a Custom Format as a Source Format

You can use the Custom Format as a Source Format when you're performing either a Quick Import or creating a new Import Tool:

n Select the Custom Format as a source format.

n Select the input dataset that you originally associated with the custom format.

n Click the Settings button.

Here's an example of some selected parameters from the Select Parameters to Show dialog in the wizard.



When you use the datasource as a source format, the selected parameters will appear in a custom settings box. They will also appear as
parameters in the Navigation pane.



Adding Custom Formats to the Browse Tree

Adding existing custom formats to the browse tree is best explained by using an example scenario.

We created an example to read GPS points located in Mexico. The GPS data is in Comma-Separated Value format (CSV).  The file extensions for
these GPS files are .MEX, so we created a Custom Format called CSV Test that reads these files, converts the latitude and longitude attributes to
points, then connects the points to create lines.

There are many .MEX files. This example explains how to browse the files, complete with geometry, from ArcCatalog.

After the Custom Format has been set up, right-click on the Original File (in the left pane) and select Edit Parameter Prompt.



This will display the Edit Parameter Prompt dialog, in which you can change the file extension that is currently associated with the customized
format. The example here shows the default CSV settings.



Change the File Type Filter to match the .MEX extension. 

Be sure to set the Associate Format with Filter textbox to Yes. This will allow you to directly read all files with the .MEX extension from the
browse tree, while at the same time applying the processing from the Custom Format. You also have the option to change the title of the source
prompt in the Data Interop tool, but in most cases this is not necessary. After all, even though you changed the extension, the source data is
still a CSV file.

You can now test the file filter by adding a new Interop Connection. Specify the format as CSV Test, and when browsing for a dataset, the
default file extension will be .MEX.  This means you have correctly associated .MEX files with the Custom Format, CSV Test.



Finish the Interop Connection to make sure there are no problems with the processing of the Custom Format. 



Test the Browse capabilities. This is done simply by navigating to the .MEX file from the browse tree. Not only can you now view files with a
.MEX extension, but the pipeline you built in the custom format is automatically applied. What started out as a CSV file of points now has line
geometry and attributes.



If you browse to the same file that you used for the Interoperability Connection, the results should be the same.



Interoperability Connections

Adding an Interoperability Connection

Some example scenarios for creating an Interoperability Connection:

Maintain database connections:

If the format you are connecting to is a database, you can maintain a live connection to the view at any time.

View formats with non-standard file extensions:

You can view formats with extensions that may not be recognized by the Browse Tree.

For example, perhaps you have a Microstation Design file, but the file ends in .agr. This file will not be picked up automatically
by the Browse Tree. When you create an Interoperability Connection, you can specify the reader, and select any file, regardless
of its extension. As long as it's a valid file, and it matches the reader, it will show up under the Interoperability connection.

Aggregate many tiles of data:

You can aggregate many tiles of data.

For example, if you had a series of MIF maps, all located in various directories, you can create an Interoperability Connection,
pick MIF as the reader, then by clicking the Advanced Browser button, you can add each directory that contains a MIF file,
regardless of where it exists on the system.

The result would be that all the MIF files would be read at the same time. If you had one master directory, then several direc-
tories below this, you could use this same method and just add the master directory.

The swizzler will search and load, all MIF files located with this master directory, as well as its subdirectories.

Add formats that require parameters like usernames and passwords:

An Interoperability Connection can be used to add formats that require that certain parameters exist before the data can be
loaded (for example, usernames, passwords, and any format parameters that might also be required).

Specify the coordinate system:

When reading a format that is not aware of its coordinate system, the Interoperability Connection can be used to specify the coor-
dinate system of the file, allowing it to overlay with other datasets.

1. From the ArcCatalog tree, click FMEInteroperability Connections, then double-click Add FMEInteroperability Connection.

The Interoperability Connection dialog appears.

2. Select the Source Format

Select the format of your source data. You can also click the Browse button to choose from the Reader and Writer Gallery.

3. Locate Source Data

Type the location of your input data. You can also use the buttons to browse for files or add multiple datasets. If the source format has
specific default settings that you want to change, you can edit them here.

For Parameters Box Help: Press the Help button, the F1 button on your keyboard, or click the question mark in the upper-right portion of
the Parameter Box.

4. Add the connection.

Click OK.



Troubleshooting

Database Table is Missing an Integer Index

In order for the ArcGIS Interoperability extension to successfully identify individual features, the database table must have an integer index.
You may need to contact your database administrator to have the indexed column added.

Please ensure that the database table has an indexed column with the following properties:

n The indexed column must be an integer type (with unsigned 32 bit values).

n The indexed column must require unique values.

n The indexed column must not allow null values.

DB2: Adding an Integer Index Column

If you already have a column in the table with unique integer values and it does not allow nulls, then you can use the following example DB2 SQL
command to make a unique index on that column:

      ALTER TABLE my_table ADD UNIQUE(my_old_id)

If you do not have a unique integer column in the table, then you need to create a new column and set the values with unique integers. The fol-
lowing example DB2 SQL commands will create a new indexed column:

      ALTER TABLE my_table ADD COLUMN my_new_id INTEGER DEFAULT NOT NULL
      CREATE SEQUENCE my_seq START WITH 1 INCREMENT BY 1 NOMAXVALUE NOCYCLE
      UPDATED my_table SET my_new_id=NEXTVAL FORmy_seq
      ALTER TABLE my_table ADD UNIQUE(my_new_id)

GeoMedia SQL Server: Adding an Integer Index

If the table's primary key is not an integer, it will be very difficult to make it work with ArcGIS unless the warehouse metadata tables are also
modified.

WARNING: Modifying the warehouse metadata tables may render the entire warehouse useless. It is strongly recommended that you do not
modify the warehouse metadata tables manually unless you are very familiar with the procedure.

Adding a column with unique integer values to a table is a simple one-line SQL command, but once the new column is added to the database
table then the associated metadata tables for the warehouse should also be modified to reflect the change. Details on how to modify the ware-
house metadata tables are beyond the scope of this help file.

The following SQL statement adds and populates an identity column to an existing table:

ALTER TABLE my_table ADD my_new_id INT IDENTITY

MSSQL: Adding an Integer Index

If you already have a column in the table with unique integer values, then you can use the following example MSSQL commands to make the col-
umn indexed and not null:

ALTER TABLE my_table ALTER COLUMN my_id INT NOT NULL CREATE UNIQUE INDEX my_index ON my_table (my_id)

WARNING: If the existing integer column is not of type INT, the preceding commands will change the type of the column. Modify the com-
mand to use the current integer type to avoid this conversion. If you do not have a unique integer column in the table, then you need to
create a new column and set the values with unique integers.

The following example MSSQL command will create a new indexed column:

ALTER TABLE my_table ADD my_new_id INT IDENTITY NOT NULL UNIQUE



MySQL: Adding an Integer Index

If you already have a column in the table with unique integer values, then you can use the following example MySQL SQL commands to make the
column indexed and not null:

  ALTER TABLE my_table MODIFY my_id INT UNIQUE NOT NULL;

If you do not have a unique integer column in the table, then you need to create a new column and set the values with unique integers. The fol-
lowing example MySQL commands will create a new indexed column:

  ALTER TABLE my_table ADD my_new_id INT UNIQUE NOT NULL AUTO_INCREMENT;

Alternatively, you can use the MySQL Administrator to add or modify an integer column to become the primary key.

Netezza: Adding an Integer Index

You need to create a new column named "ARCGIS_ID" and set the values to unique integers. The following example Netezza SQL commands will
create a new index column:

CREATE SEQUENCE my_seq;
CREATE TABLE temp_table AS SELECT CAST (NEXTVAL('MY_SEQ') AS INT4) AS ARCGIS_ID,* FROM my_table;
DROP SEQUENCE my_seq;
DROP TABLE my_table;
ALTER TABLE temp_table RENAME TOmy_table;

Oracle: Adding an Integer Index

If you already have a column in the table with unique integer values, then you can use the following example Oracle SQL commands to make the
column indexed and not null:

ALTER TABLE my_table ADD UNIQUE (my_old_id);
ALTER TABLE my_table MODIFY (my_old_id NOT NULL);

If you do not have a unique integer column in the table, then you need to create a new column and set the values with unique integers. The fol-
lowing example Oracle SQL commands will create a new indexed column:

ALTER TABLE my_table ADD my_new_id INTEGER UNIQUE;
UPDATE my_table SET my_new_id = ROWNUM;
ALTER TABLE my_table MODIFY (my_new_id NOT NULL);

PostGIS/PostGRES: Adding an Integer Index

If you already have a column in the table with unique integer values, then you can use the following example PostGRES SQL commands to make
the column indexed and not null:

ALTER TABLE my_table ADD UNIQUE (my_old_id);
ALTER TABLE my_table ALTERmy_old_id SET NOT NULL;

If you do not have a unique integer column in the table, then you need to create a new column and set the values with unique integers. The fol-
lowing example PostGreSQL commands will create a new indexed column:

ALTER TABLE my_table ADD my_new_id INTEGER UNIQUE;
CREATE TEMPORARY SEQUENCE my_seq;
UPDATE my_table SET my_new_id = NEXTVAL('my_seq');
ALTER TABLE my_table ALTERmy_new_id SET NOT NULL;

Database View is not Available in Spatial Reader

Netezza: Exposing a View to the Spatial Reader

The Netezza Spatial Reader only considers a view to be a Feature Type if it is listed in the GEOMETRY_COLUMNS table. If the view is based on a
single table, you can use the following example Netezza SQL command to expose it to the Spatial Reader:



INSERT INTO geometry_columns SELECT f_table_catalog, f_table_schema, 'my_view', f_geometry_column, geometry_type, coord_dimen-
sion, srid, dissolve_column FROM geometry_columns WHERE f_table_name='my_table';

Oracle Table is Missing a Spatial Index

In order for the ArcGIS Interoperability extension to successfully display different zoom levels for an Oracle Spatial table, the Oracle table must
have a spatial index. You may need to contact your Oracle database administrator to have the spatial index added.

The following example Oracle SQL command will create a spatial index for a table (for the geometry column named 'geom'):

CREATE INDEX my_index ON my_table(geom) INDEXTYPE IS MDSYS.SPATIAL_INDEX;

ArcGIS Does Not Correctly Display all the Feature Classes from an Interoperability Connection

Each ArcGIS application, such as ArcCatalog or ArcMap, has its own Data Interoperability extension that reads Interoperability Connections.

If you are viewing an Interoperability Connection in ArcMap, and then edit the same Connection in ArcCatalog, your changes will not be rec-
ognized in ArcMap until ArcMap is restarted. If you do not restart ArcMap, but instead drag-and-drop a new Connection feature class from Arc-
Catalog to ArcMap, then you will get an error. Please restart ArcMap after you edit an Interoperability Connection.

ArcCatalog Keeps Re-Indexing my Interoperability Connection to a GeoMedia Access Warehouse or other MS
Access Database

The MS Access 2.0 ODBC driver opens databases with read/write access, which updates the modification timestamp on the database file. This
forces the ArcGIS Interoperability extension to re-index the database to ensure that the data being used in ArcGIS is current.

This problem occurs only with the older MS Access 2.0 databases. You can work around the re-indexing of MS Access 2.0 databases by using
Windows Explorer to set the "Read-only" attribute on the database file, or by upgrading to a current version of MS Access.
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